Exchange Upgrades - Email Delays
Incident Report for Triarom Data Services Status Page
Resolved
We have completed this maintenance.
Posted Oct 02, 2022 - 22:56 BST
Update
We’re continuing to apply updates to our Exchange server - mail delivery may still be delayed.
Posted Oct 02, 2022 - 18:29 BST
Identified
We’re working on applying software updates to our Microsoft Exchange email server - during these works emails may take longer to be delivered, but will arrive eventually.

We expect these works to take a few hours and will close this issue once we are confident the system is working at full capacity again.
Posted Oct 02, 2022 - 11:19 BST