TDS Services Unavailable
Incident Report for Triarom Data Services Status Page
Resolved
Our supplier has resolved this issue.
Posted Feb 11, 2024 - 18:29 GMT
Identified
Our supplier has dispatched engineers to the servers to investigate a loas of power
Posted Feb 11, 2024 - 10:05 GMT
Investigating
We're investigating a fault in the TDS platform and will update as soon as possible
Posted Feb 11, 2024 - 10:03 GMT
This incident affected: Triarom Desktop Services (TDS Remote Access Gateway, TDS Domain Controllers, TDS Virtual Machines) and TDS Network (TDS Edge Router 2, TDS Internet Access).